Network Migration 专题¶
互联网中有很多站在“过渡与变革期”的时刻, 包括但不限于:
- 3 -> 4 -> 5G
- IPv4 -> IPv6
- WiFi <-> Cellular
- Transport Layer Mechanism
- 比如 MPTCP, QUIC 相较于传统 TCP
本模块我们计划汇总整理这些"过渡期"重要时刻, 哪些团队站了出来, 发现了什么问题, 采用什么样的方法解决
(1) 3/4/5G
- [MediaTek WhitePaper 20] 5G NR and 4G LTE Coexistence
- [SIGCOMM 20] Understanding Operational 5G: A First Measurement Study on Its Coverage, Performance and Energy Consumption
- [NSDI 16] iCellular: Device-Customized Cellular Network Access on Commodity Smartphones
- [SIGCOMM 14] Control-Plane Protocol Interactions in Cellular Networks
- [MobiCom 24] M2HO: Mitigating the Adverse Effects of 5G Handovers on TCP
- [MobiCom 20] iCellSpeed: Increasing Cellular Data Speed with Device-Assisted Cell Selection
| 论文 | 核心 | 推荐系数 | 亮点与评价 |
|---|---|---|---|
| MediaTek 4to5G | 4/5G过渡期的频段设计 | 0 | 没啥看点, 主要聚焦物理层和频段, 适合搞通信的 |
| CrossLayer 5G | NSA/SA 的"初代" 5G 测量 | 2 | 纯测量, 记点结论得了 5G NSA 状态机画的不错; 半实物仿真图画的也不错 |
| iCellular | UE 基于底层蜂窝信息, 进行多运营商 (Multi-PLMN) 的"无缝"+"正确"切换 | 5 | 惊为天人, yuan神大作, 膜拜了! 实测发现:多运营商的潜力没有被充分发挥 (固执不切/切错/超时) 根因:终端拿不到底层蜂窝信息 + 单个 运营商 没有全局视图,全局视图只能在 终端 上构建 |
| CNetVerifier | 3G/4G 控制面信令交互"耦合"导致的问题分析 | 5 | yuan神大作, 继续膜拜! (1) cross-layer, cross-domain, cross-system 交互导致的问题 (2) 问题出在交互本身: 必要的协作没有做好 + 不必要的耦合却被引入 (3) 非常适合入门学习 3/4G 控制层信令 |
| M2HO | TCP 利用 UE 链路层信息, 进行rwnd调节. 确保无缝切换+高带宽 | 5 | 深度好文! 切换问题 -> 需要跨层优化 问题: 5G 网络 TCP CUBIC 带宽利用率低 根因: 切换过程中链路层与 TCP 的三种不当交互 解法: 进行 "链路层+传输层"跨层优化 |
| iCellSpeed | 5 |
(2) WiFi-Cellular
- [MobiCom 14] A Practical Traffic Management System for Integrated LTE-WiFi Networks
- [CellNet 12] Exploring Mobile/WiFi Handover with Multipath TCP
- [SIGCOMM 21] XLINK: QoE-Driven Multi-Path QUIC Transport in Large-scale Video Services
- [IMC 14] WiFi, LTE, or Both? Measuring Multi-Homed Wireless Internet Performance
- [SIGCOMM 17] Wi-Fi Goes to Town: Rapid Picocell Switching for Wireless Transit Networks
- [NSDI 15] Towards Wifi Mobility without Fast Handover
- [CoNEXT 10] Mobile Data Offloading: How Much Can WiFi Deliver?
| 论文 | 核心 | 推荐系数 | 亮点与评价 |
|---|---|---|---|
| ATOM | WiFi-LTE 做动态调度+无缝切换 | 5 | 超级好文章! 大道至简! 依旧是"任何系统问题都可以通过中间层解决" Key Insight: 不必维持IP, 维持完整的HTTP应用层session即可 做法: 在核心网侧, 建立 ATOM: 为网络侧和用户终端侧均建立 HTTP Proxy |
| WiFi MPTCP | |||
| XLINK | |||
| Multihome | |||
| WiFiRoaming | |||
| WiFi FastHandover | |||
| 3G WiFi Deliver |
(3) IPv4 -> IPv6
- [IMC 25] Towards a Non-Binary View of IPv6 Adoption
- [SIGCOMM 14] Measuring IPv6 adoption
- [RFC 4213] Basic Transition Mechanisms for IPv6 Hosts and Routers
- [RFC 6877] 464XLAT: Combination of Stateful and Stateless Translation
- [RFC 8305] Happy Eyeballs Version 2: Better Connectivity Using Concurrency
- [RFC 8170] Planning for Protocol Adoption and Subsequent Transitions
| 论文 | 核心 | 推荐系数 | 亮点与评价 |
|---|---|---|---|
| TBD | |||
| TBD | |||
| TBD | |||
| TBD | |||
| TBD | |||
| TBD |
(4) Transport Layer
- [IMC 11] Is it Still Possible to Extend TCP? (MPTCP)
- [NSDI 12] How Hard Can It Be? Designing and Implementing a Deployable Multipath TCP (MPTCP)
- [SIGCOMM 17] The QUIC Transport Protocol: Design and Internet-Scale Deployment (QUIC)
| 论文 | 核心 | 推荐系数 | 亮点与评价 |
|---|---|---|---|
| TBD | |||
| TBD | |||
| TBD |